Taxonomy Image module contained a flaw which permitted users to bypass Drupal’s protection against malicious uploads, permitting remote code execution and XSS.

From the Drupal advisory, SA-CONTRIB-2012-133

The module did not sufficiently filter retrieval of taxonomy images, allowing users to bypass Drupal’s normal file upload protections to install malicious HTML or executable code to the server.

This vulnerability is mitigated by the fact that an attacker must have the permissions “administer taxonomy” and “administer taxonomy images”, and that the fix for SA-2006-006 – Drupal Core – Execution of arbitrary files in certain Apache configurations should prevent code execution in typical Apache configurations.